Apache 64bit and Php 64 bit


  • | 284 points

    I have a problem,

    That I understand but I really don't. So I have following the tutorial of how to change the Apache and PHP Version to 64 bits.

    The Apache and PHP Version that I downloaded are the same number versions with the 32 bit that Laragon brought, so don't get me wrong.

    The problem is, when I'm about to change my Apache version through Laragon, it always says " Your PHP Version (php-7.0.10-Win32-VC14-x64) & Apache Version (httpd-2.4.23-win64-VC14) are not compatible! Pleache check WIn64 or Win32 on the versions.

    Okay then, it says my PHP version is not compatible with the Apache. so I changed the PHP first from 32 bits to 64 bits, and it succeed. But even I did so, it still the same error!

    If I run Apache 32 bits with PHP 7 64 bits, the Apache will fail to start.

    I'm thinking of changing Laragon to another similiar application instead, because running development on this localhost seems really slow, it even faster to running development through my cloud server on Digitalocean rather than on my localhost


  • administrators
    | 46775 points

    @pramadiputra : The Antivirus and Firewall may affect much on performance on Windows.

    If you want to use PHP 32-bit with Apache 64-bit and vice versa, you can use PHP Non Thread Safe version (which as -nts- in the download link)

    From Laragon 2.1.0, you can use nginx so you don't care about PHP 32-bit or 64-bit, Thread Safe or Non Thread Safe,...

    Laragon is designed with performance and speed in mind, so I hope it helps.


  • | 284 points

    hi Leokhoa,

    Thanks for the Reply. But how do I use Nginx ? When I'm about to enable it, I couldn't


  • administrators
    | 46775 points

    I've released Laragon 2.1.0 with nginx support here:
    https://forum.laragon.org/topic/239/laragon-2-1-0-released-with-nginx-support

    You can install it to another folder, tested performance first then switch to.


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.