Installing SuiteCRM - setting the permissions

  • | 533 points

    Hi everyone,
    I've been using Laragon for my WordPress local dev, and it has been a great tool so far - much faster and more reliable than XAMPP, which I used for a long time.
    I am now trying to install SuiteCRM on Laragon, and have come to an issue.
    The official SuiteCRM installation instructions require that the permissions within its installation folder be set in a particular way.
    Here are the instructions:
    Set the correct permissions on the SuiteCRM directory (Linux):
    sudo chown -R www-data:www-data .
    sudo chmod -R 755 .
    sudo chmod -R 775 cache custom modules themes data upload
    sudo chmod 775 config_override.php 2>/dev/null
    That www-data needs to be replaced by the actual system user that your web server runs under. This varies depending on your operating system. Common web server users are as follows:
    www-data (Ubuntu Linux/Apache)
    apache (Linux/Apache)
    nobody (Linux/Apache)

    I looked up the 'system user' and Group for Apache, at the httpd.conf file of the Apache version I'm using, and I found that both the User and the Group are set to 'daemon'.
    However, when I try to use it in the Laragon Terminal, as : chown -R daemon:daemon . I get a message that the user "daemon" is not recognized. The terminal is able to recognize Linux commands, like 'ls -l' , etc.
    I also tried the ones listed above, www-data, etc, as well as 'laragon', but without success.
    I'm not even sure if this is absolutely necessary, but when I go through the SuiteCRM forum, - there is a lot of talk about the file permissions not being set properly, as the cause of most problems the people are facing.

    Any help would be greatly appreciated.

  • | 533 points

    Update: I just ignored the instructions about the permissions, and it seems to have worked fine.
    I'll keep an eye for any issues related to permissions, and my plan is to tweak them, if needed - in Windows Explorer, for the SuiteCRM installation folder, at laragon/www, using Properties/Security/Advanced options.
    Hope this may be of use to others.

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.