Git-Bash task missing, trouble adding to ConEmu

  • | 982 points

    My ConEmu is working great with Cmder, mintty, etc., but for some reason Git-Bash was not included in the tasks that came with Laragon. I’m having a heck of a time adding it so it opens in another tab rather than a separate instance. I tried cloning the mintty task and just changing the locations but that didn’t work. Git-Bash.exe is located at


    I’ve scoured the net and tried lots of suggestions but no joy. Can anyone offer any tips? Any idea why the Git Bash task was missing from the ConEmu shipped with Laragon?

  • | 16118 points

    @lumi you could try adding the one in the git folder:

    • C:\laragon\bin\git\git-bash.exe

  • | 982 points

    Thanks for that. Of course I saw git-bash there and tried adding it, but it always runs in a separate window instead of another tab in ConEmu as I wanted. I made things more interesting by not installing laragon to c:, but rather my w: drive, which had me try

    W:\laragon\bin\git\git-bash.exe -new_console:d:W:\laragon\www

    as my command. See anything I’m doing wrong?

  • | 16118 points

    @lumi I'm not sure, try google: "add git bash to ConEmu windows 10" which has several questions and answers. Work through the answers and please post back the solution you get to work.

  • | 982 points

    Just reporting back that I was adding the wrong command, namely


    The right command is

    laragon\bin\git\bin\sh.exe -new_console

    Hope this helps someone.

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.