libssh2.dll icuuc66.dll are missing again! Php and Apache update doesn't help


  • | 970 points

    Hello, Leokhoa!
    You know, I came upon the same problem, as 2 years ago..
    I installed your new release of Laragon: https://github.com/leokhoa/laragon/releases/download/5.0.0/laragon-wamp.exe
    And when starting Apache, I got the same error messages:
    " libssh2.dll and icuuc66.dll are missing "
    Last time I updated apache and php, it had solved the problem, but now updating didn't help.
    What to do in that case, can you give an advice, please?

    Windows 7 X64 Pro

    Thank you!


  • | 970 points

    Adding a new apache version httpd-2.4.48-win64-VS16 helped, no errors when starting apache.
    Now I'm testing PHP-8.0.6-Win32-vs16-x64, it seems without errors so far..

    That 5.0.0 release of laragon doesn't support SQL 8.0.25 ,
    I tried the solution from here:
    https://forum.laragon.org/topic/1766/laragon-4-0-16-mysql-8-0-18-mysql-cannot-start/3
    It seems to solve the problem, SQL 8 started, I didn't test local sites yet, if any issues will rise, I'll inform about it..

    So, now in my installation of Laragon the following components works:
    PHP 8, Apache 2.4.48 (VS16), and SQL 8..
    Seems no error reporting now, after testing sites I shall write about results


  • | 970 points

    Well, a SQL database isn't possible to create at MySQL 8 version, some errors about password reported.. I have to use SQL 5.7.33 for creating database.
    So, now the following components versions are used:
    PHP 8, Apache 2.4.48 (VS16), and SQL 5.7.33
    I suppose, there is no way to use SQL 8 in Laragon at that moment.
    Hope, Leokhoa shall do something intetersting with that soon..


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.