Firefox afraid of Laragon's self-signed SSL certificate?


  • | 367 points

    Hi leokhoa, first of all thank you SOOO much :) you have ended 3 months of spending half my time tweaking local settings in 4 other setups. (Windows 10)

    I added Laragon's SSL certificate by using Menu > Apache > SSL > Add to Trust Store

    But, FireFox still gives error:

    mysite.test uses an invalid security certificate.
     
    The certificate is not trusted because it is self-signed.
     
    Error code: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT
    

    I can see the certificate in Windows' Certificate Manager under "Trusted Root Certification Authorities/Certificates". Might not be a problem while working in WordPress.

    TIA


  • | 9869 points


  • | 367 points

    Well, For the the article in the second link, FireFox already recognized the self-signed cert from Laragon.

    For the first link, I did a couple of things:

    • Added to c:\laragon\etc\apache2\httpd-ssl.conf, line 3: SSLCertificateFile "${SRVROOT}/conf/server.crt"
      This did not change the warning so I reverted my changes
    • Generated a new cert and modified c:\laragon\etc\apache2\sites-enabled\auto.mysite.test.conf lines 24-25:
        SSLCertificateFile      C:/Users/enrique/.ssh/server.cert
        SSLCertificateKeyFile   C:/Users/enrique/.ssh/server.key
    

    Laragon recognized this newly generated cert and showed a green lock by apache, but no change in Firefox.

    I did manually type in https://... in the address bar, and that causes Firefox to show a dialog asking you to acknowledge a "security exception" -- presumably using the self-signed certificate but flagging it as unsafe.

    By the way Chrome gives the "Not secure" warning as well.

    I'm not testing any sandbox transactions or anything yet, so for now I should be fine with no SSL.
    Thank you for the suggestions.


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.