Enable module_deflate internal error - Laragon 5.0


  • | 3109 points

    OK I am not a professional here but because I have worked with all types of online open source software for hosting on windows for 20 years or so I pretty much know how to get the website live and configure, tweak and secure for the most part but so far there has been many issues here that I have personally took the time to address and discovered, obviously tried everything to work it out on my own like i been doing for so many years for the most part but with 5.0 Laragon I am disappointed because im running out of ideas and solutions to issues and ongoing problems.

    Yes I seem to be having a few issues with your new version Laragon 5.0 (other parts of the forum I have also mentioned and stated the specific issues related to the new 5.0 software)

    I noticed you still haven't mentioned anything on how to use your software as a Live Production Server (which i managed to work out on my own for the most part) but you did mention to me in another post that you would make a tutorial for us all on how we can use your Laragon 5.0 software for hosting ??? You did get me excited i won't lie but remember we have all been patiently waiting now for roughly 2 weeks + ago.

    I notice you been answering other forum members but it's like you have completely ignored me for what reason I don't know but please do tell me if I have said anything to offend you.

    In the meantime I have posted the error I am receiving when trying to enable module deflate on apache.
    click here

    So much future potential for this software but lack of support for the most part. I do understand we all have jobs outside of this but when I see the Developer/Admin has been active answering other posts but ignoring mine you start wondering why..... am I correct ???


  • administrators
    | 131219 points

    Hi @MarkAnthonyMtl ,

    Sorry I prioritize on questions that I can answer quick. For hosting, you should use Linux instead on Windows.

    Regards to your error, it is not related to laragon 5 or 4.

    AH00112: Warning: DocumentRoot [C:/laragon/bin/apache/httpd-2.4.47-win64-VS16/docs/dummy-host.example.com] does not exist
    

    dummy-host.example.com looks strange to me. Please check why you have the path.


  • | 3109 points

    Hi Thank You for responding quickly, yes I don't know why earthier but the dummy.host that is coming up as in the apache error is being created by Laragon as i have doubled checked and there are no other hosting software's on the server currently.

    Also to verify with you, no there is nothing else currently installed on the windows 10. Actually I just reformatted the server yesterday with a new Windows Operating System 10 (with all the new updates) so it's a clean install with no other software except Laragon and the bare minimum which is windows firewall and windows defender and windows antivirus.

    I just thought of this right now maybe just maybe it is something to do with possibly the name of the file that was created for vhost
    i was using nginx before but there was a 502 gateway problem so for now im stuck using apache so here is the path and the default place that I configured plus ssl is enabled

    C:\laragon\etc\apache2\sites-enabled
    auto.my_domain.test.conf

    C:\laragon\etc\ssl
    is where I placed a valid key and cert

    C:\laragon\www\myfolder
    the website folder

    Using phpmyadmin with .mydomain.sql imported and database already setup and created

    Does something above need changing or is that OK because It's weird because I am able to host it live but unfortunately can't enable module_deflate??? If it does have something to do with changing the name of the file then perhaps why i was getting gateway 502 errors with nginx. I know that apache is not as fussy as nginx I could simply use a .htacess in the root folder and most likely it would work without enabling the module_deflate but beforehand I would like to be able to solve this issue instead of bypassing it.


  • administrators
    | 131219 points

    @MarkAnthonyMtl : Something is strange to me:

    1. On Laragon, mod_deflate is enable by default
    2. dummy-host.example.com could come from your former Apache setting

    Therefore you can:

    1. Add another Apache version:
      https://forum.laragon.org/topic/165/tutorial-how-to-add-another-apache-version?page=1
    2. Check your vhost:

    By the way, remember to remove the auto. prefix if you want to persist your changes.


  • | 3109 points

    @leokhoa

    Yup that fixed the problem, upgraded apache, Thank You so much !!


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.