Windows permissions issue when creating WordPress site


  • | 4248 points

    Hi everyone.

    Using Laragon 2.05 on Windows 10, I went to create a new WordPress project as I have done many times. Before completing the installation it asked for administrator rights which I said okay, then it said I didn't have the correct permission!? Now I have a folder sitting in laragon/www which I can't open, delete or modify the security settings for? Any ideas?

    After googling around and checking this link: http://stackoverflow.com/questions/2928738/how-to-grant-permission-to-users-for-a-directory-using-command-line-in-windows

    I have tried the following commands with the command prompt as administrator:

    C:\WINDOWS\system32> icacls "C:\laragon\www\wordpress-site" /grant dominic:(OI)(CI)F /T
    C:\laragon\www\wordpress-site: Access is denied.
    Successfully processed 0 files; Failed processing 1 files
    

    When I try to modify the security settings I have the following (image below) which all leads to "Access denied" or something to that effect.

    0_1475484282654_nmr.PNG

    Any help would be appreciated!


  • | 4248 points

    Just restarted my PC and the folder is no longer there?! I'll upgrade Laragon now and hope this doesn't happen again!


  • administrators
    | 56177 points

    @haakym : When Laragon asking for Administrator right, it wants to add host entry to the hosts file. As the Quick-create feature is idempotent, if you see the same issue, I think you can delete the folder and just try re-creating.


  • | 4248 points

    @leokhoa Thanks a lot I'm going to give it another shot now, just installed 2.1.0

    Quick question, was I supposed to remove 2.0.5 (apache) before installing 2.1.0 (nginx)? As I just installed on top of it and I still see apache as the server option - no big issue really but just curious!


  • administrators
    | 56177 points

    @haakym : With Laragon, you can use both Apache & Nginx. Apache for legacy apps and Nginx for speed.
    When having Apache, Nginx will listen on port 8080 by default. You can change their ports on Menu > Preferences > Services & Ports.
    If you don't need Apache or Nginx, just uncheck the service you don't want to use.

    So the short answer is you don't need to :)


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.