Setting up Wordpress with SSL using Laragon


  • | 1780 points

    Hey Leo, thanks for the help before. I'm here to ask a simple question, or at least what I believe to be easy for you. I've gone ahead and enabled SSL on Laragon and it generated a SSL certificate. I have also enabled SSL in the settings of Laragon. But when forcing Wrodpress to use SSL, it simply says, "This site can’t provide a secure connection.".

    Any ideas? What am I doing wrong? I'm using my pc's local ip and accesing the site from another computer. I added the line , "define('FORCE_SSL_ADMIN', true);" into wp-config.php


  • administrators
    | 123015 points

    @MightyRufo: What is the Details of the error?
    What web server are you using (Nginx, Apache)?
    What if you create an empty project and check SSL?
    Some pics will be useful.


  • | 1780 points

    Trying an empty project gives me the same message in google chrome, which is what gave me the "This site cannot provide a secure connection" message. As for error messages, that's the only one I can provide.

    What would you like a screenshot of?


  • administrators
    | 123015 points

    So it's not Wordpress configuration.
    For Chrome click on Details, you'll see exactly the reason. It would be helpful if you test on Firefox (or whatever) also.


  • | 1780 points

    Chrome says : ERR_SSL_PROTOCOL_ERROR

    The error for Firefox was.. certainly longer haha
    0_1475725300759_2016-10-05_23-41-19.png


  • administrators
    | 123015 points

    Are you browsing your project using IP? I've tested Laragon auto-generated SSL feature and see no issue.
    You may try creating a self-certificate yourself follow Kurre's instruction here:
    https://forum.laragon.org/topic/106/laragon-and-let-s-encrypt


  • | 308 points

    @MightyRufo hello, did you solve your problem ? I just installed new Laragon, everything seems that it's working with nginx besides https. I'm getting :

    "asd.dev:8443 uses an invalid security certificate. The certificate is not trusted because it is self-signed. Error code: SEC_ERROR_UNKNOWN_ISSUER"

    I created clean project, nginx is added in firewall exceptions, it should work...


  • | 308 points

    I would like to inform that I have that same issue on my another computer. both are working on Windows 10 with newest updates. Maybe it will be helpful in next releases. Have a nice day guys


  • administrators
    | 123015 points

    @MonsterDream : Glad to know that. Nice day :)


  • | 560 points

    First of all, Log in to your domain registrar and add a CNAME record like below:

    Type: CNAME
    Host: _acme-challenge
    Value: Your WordPress staging URL
    Once done, go back to the SSL Certificate tab and click on Verify DNS. It will cross-check the settings and notify you accordingly. Then, click on the INSTALL fffCERTIFICATE button to get a free SSL certificate for WordPress. Also, you should check the WordPress SSL site link with WordPress on Laragon.


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.