How to change the idle/stand-by timer?


  • | 636 points

    Hello,

    Pretty new to Laragon, so far so good, except for 1 thing: after a few minutes of not interacting with the local server, it appears to go on a sort of stand-by mode? Every time I wait a couple of minutes and then make a new request to a webpage, any webpage, it takes really long to load as if it has to recover from the stand-by that it put itself in. After the first request, every other is fast as normal. And then after minutes of not interacting again, slow loading, etc...

    Now I'm not sure if I'm even right about this feature/bug. I guess that this was build in to reduce RAM usage when not using the server. But is there a way to change this to like 20 minutes of not interacting?


  • administrators
    | 48370 points

    @elbojoloco : You can tune MySQL settting:
    Open MySQL/MariaDB folder (Menu > MySQL > Version (xxx) > dir:xxx), you will see some sample setting files (my-huge.ini. my-large.ini,...), select one of them and overwrite my.ini (backup first).


  • | 636 points

    Is it the "interactive-timeout" option?

    If it is, I don't see where i can change the timing, I can only comment/uncomment it, but I don't want it completely disabled because then it'd take up ram when I'm not using it.


  • administrators
    | 48370 points

    No, it isn't.
    Most of them are under [mysqld] directive.
    Here is a sample from my-large.ini

    [mysqld]
    port		= 3306
    socket		= /tmp/mysql.sock
    skip-external-locking
    key_buffer_size = 256M
    max_allowed_packet = 1M
    table_open_cache = 256
    sort_buffer_size = 1M
    read_buffer_size = 1M
    read_rnd_buffer_size = 4M
    myisam_sort_buffer_size = 64M
    thread_cache_size = 8
    query_cache_size= 16M
    # Try number of CPU's*2 for thread_concurrency
    thread_concurrency = 8
    

  • administrators
    | 48370 points

    @elbojoloco: Did the setting solve your issue?


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.