Terminal won't open


  • | 273 points

    Re: laragon Terminal opening issue

    Hi, new to Laragon but it seems pretty awesome. I am the same issue as nishan in this above thread though. When I click Terminal or hit Ctrl-Alt-T no Terminal opens. This should open Cmder correct? Do I need to actually install Cmder separately at a particular path?

    Thanks!


  • administrators
    | 66720 points

    What is your Laragon version (Full, Lite)? your OS?
    I had tested Laragon with many versions of Windows 7/8/8.1/10/2012 32-bit/64-bit and never seen this kind of issue.
    As Laragon is isolated, you can install Cmder as different path to check if Cmder (ConEmu) works on you system.


  • | 273 points

    Windows 10
    Laragon 2.1.5 Full Nginx + PHP 7 (tried Full Apache version too)

    Installed Cmder seperately and it runs fine, but Terminal button still doesn't load anything.

    Found a sorta work around: Quick Create > Laravel opens a normal windows Cmd prompt, and I can Ctrl-C that and run my server commands from in there. But obviously that's not ideal.

    Anything else I'm missing here? Is it possible to access the Laravel "server" from a seperate Cmder instance?


  • | 273 points

    Figured this out, at least a solution that worked for me. I copied the Cmder.exe file into the laragon/bin/cmder folder and it worked after that. Maybe failed to install that for some reason (on a work computer, might be permissions or something)

    Up and running now!


  • administrators
    | 66720 points

    Cool! Glad to know it worked.
    I will figure out why Cmder.exe is missing (Strange - I don't think it is due to permissions) and will show an alert in that case.
    Cheer!


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.