Installed and switched to MySQL 5.7 but Laragon still runs MariaDB


  • | 1274 points

    Hi, I extracted MySQL 5.7 into the folder as the tutorial. On Laragon it says MySQL mysql-5.7.17-winx64 started.

    When I click on Database button, it shows in PHPMyAdmin "Server type: MariaDB". I tried to migrate my DB which uses JSON column and it's showing error. So I think it's still running MySQL although on the UI it's saying MySQL. What do I do?


  • administrators
    | 56177 points

    @komirad: Did you restart Laragon?


  • | 1274 points

    @leokhoa Yes, first I stopped and start with the UI. Then I tried exiting and starting up. Both didn't work. I didn't close Cmder, but that doesn't seem connected.

    If it matters, I have configured mariaDB to use 3307 instead of 3306. Now after switching to MySQL it's still 3307. Maybe it's due to the config file?


  • administrators
    | 56177 points

    It's not the configuration issue as Laragon will auto update your prefer port to even other vesion.
    Maybe you need to restart your Windows as I guess mysqld.exe of MariaDB is still running.


  • | 1274 points

    When I click stop, and checked in task manager, mysqld.exe does disappear.

    I switched port to 3306 and stop/start, but MariaDB still runs instead.

    I right clicked mysqld.exe in Task Manager and "Open file location" it goes to C:\laragon\bin\mysql\mysql-5.7.17-winx64\bin but for some reason my PHPMyAdmin still shows:

    Server type: MariaDB
    Server version: 10.1.19-MariaDB - mariadb.org binary distribution

    wat. :D


  • administrators
    | 56177 points

    @komirad: I guess PHPMyAdmin read the information from current data dir.
    If you stick to use JSON, consider to upgrade the MySQL data dir:
    https://dev.mysql.com/doc/refman/5.7/en/mysql-upgrade.html


  • | 1274 points

    I took my other MySQL data (Running on another application) and placed it into Laragon's data dir. It runs but PHPMyAdmin still shows MariaDB.

    I tried to enter mysql by cmder:
    λ mysql -u root
    Welcome to the MariaDB monitor. Commands end with ; or \g.
    Your MySQL connection id is 13
    Server version: 5.7.17-log MySQL Community Server (GPL)

    Copyright (c) 2000, 2016, Oracle, MariaDB Corporation Ab and others.

    I went into Laravel's artisan tinker to do $mysqli->server_info; and got "5.7.17-log".

    So I think the issue is only at PHPMyAdmin showing the wrong version.


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.