.dev domain not pointing to project folder


  • | 1274 points

    I have multiple projects running on the document root with no problems.

    I just added a Laravel 5.4 project named "oauth-client". When I clicked on it it brings me to oauth-client.dev, but it's the "Index of /" page (my document root). Which means it's pointed at the default "localhost" instead of using the generated vhost .conf. In other words, to access this project, I need to go to http://oauth-client.dev/oauth-client/public/

    How do I solve this?


  • administrators
    | 52456 points

    @komirad: Can I see the content of the Virtual host?


  • | 1274 points

    @leokhoa It's auto generated

    <VirtualHost *:80>
    DocumentRoot "C:/Users/komirad/Desktop/projects/oauth-client/public/"
    ServerName oauth-client.dev
    ServerAlias *.oauth-client.dev, 5348ed19.ngrok.io
    <Directory "C:/Users/komirad/Desktop/projects/oauth-client/public/">
    AllowOverride All
    Require all granted
    </Directory>
    </VirtualHost>

    If you want to use SSL, enable it by going to Menu > Apache > SSL > Enabled


  • administrators
    | 52456 points

    @komirad: From the configuration, I see no way you can not access oauth-client.dev
    Maybe a restart may fix your issue (Reason: to release some former httpd.exe processes).

    To avoid restarting, you can stop Laragon, check if there are any httpd.exe processes still running and kill them.


  • | 1274 points

    Killing the process via task manager seems to have solved it. Thanks!


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.