version 1.0.3?


  • | 2855 points

    Did I just download the 1.0.3?

    I just tried the new download, which states : 1.0.3. in the title bar. (1.0.2. on the website)
    It refuses to run my php install, since in runs 32bits mode, and my php is 64bits. I have a 64 bits computer.
    Tried to install a newer apache (64 bits), but then apache nags about not finding a path.

    I don't know how to continue now. At home I have the 1.0.2 and is running the php 7.0.2 64bits.


  • | 2855 points

    My solution for now is installing the php 7.0.2 in 32bits :-(


  • administrators
    | 68996 points

    For simplicity & portability, Laragon use 32 bits Apache2 & PHP.
    If you want want to use 64 bits, you must download 64 bits version for BOTH and use PHP extensions 64 bits


  • | 2855 points

    Well, I did. I have the apache-2.4.18_64vc14 in the correct directory, but somehow it won't boot.
    No message whatsoever. No logging, that I know of (looking in the apache-log directory).

    I found out that for some weird reason, my bin directory was missing in my apache download

    Now that I fixed that, it still won't start and the error message in the information popup is a puzzle because the information is not all visible there. (Can that window be bigger, or can you put some extra linebreaks before showing it?)

    I manually changed the "httpd-ssl.conf" because there was still an important reference to a missing directory.(and laragon didn't change it for me). I had to copy the conf\ssl directory, because that was missing too.
    And now : it runs like a train.

    BTW: Using this for Silex development, I hope you wouldn't mind ;-)


  • administrators
    | 68996 points

    Cool! Good to hear Laragon is used for many types of projects :)


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.