[Solved] Unable to create projects with Laragon


  • | 490 points

    I'm completely new to Laragon and have recently downloaded it as a tool to help me learn php and the laravel framework.

    The problem I'm having is that when I run Laragon and click the Start All button, everything seems fine, I can click on the Web button and it'll take me to the localhost etc, however when I right click and select "Quick create" i get a message dialog saying "You must click [Start All] first!"

    You'll notice that the service is running yet I'm still getting the message dialog when attempting to create any project type.
    0_1490300230419_laragon.png

    I have no idea why this is happening and seem to be the only person who has encountered this problem.

    Can anybody help?

    Thanks


  • administrators
    | 62136 points

    @Ryucchi:
    Why only nginx it is running?
    Please start also MySQL as Laragon will need it running to auto create MySQL database for you.
    For example, if you want to create "coolapp" project, you'll have:

    • C:\laragon\www\coolapp
    • a database name "coolapp"

  • | 490 points

    @leokhoa I was following directly the tutorial here: http://www.danfletcherblog.ca/2017/02/install-laravel-5-4-windows-fast-using-laragon-✔/

    The steps are literally:

    First, install Laragon

    Get the download from this page: https://laragon.org/download.html

    Click either “Full + Nginx” or “Full + Apache” – whatever your preference. If you don’t have a preference, choose Nginx. It’s the server used on Laravel’s Homestead.

    Once download finishes just run the installer, and keep all the default settings.

    1. click “Start All”
    2. right-click anywhere on the window
    3. click on “quick create”
    4. select and click on “Laravel”
    5. type the name of your project
    6. click “OK”

    Because it didn't mention installing MySQL or Apache I assumed it came packaged with the Laragon install and the default settings would deal with everything else.


  • administrators
    | 62136 points

    @Ryucchi: You don't need to install MySQL as Laragon Full already has MySQL but you need to start it (please check Menu > MySQL)


  • administrators
    | 62136 points

    On the tutorial you mentioned, see MySQL is running...

    alt text


  • | 490 points

    @leokhoa I had to disable MySQL because it was throwing up errors when starting the services:

    MySQL 5.1.73
    0_1490380020984_laragon_MySQL.png

    MariaDB
    0_1490380111926_laragon_mariadb.png

    Are you sure I don't have to download MySQL or MariaDB?

    Thanks


  • administrators
    | 62136 points

    @Ryucchi : From your images, I guess there is a collision between MySQL 5.1 & MariaDB 10.2. Here is how to solve it:

    1. Shutdown all services
    2. Rename C:\laragon to C:\laragon.old
    3. Re-install Laragon Full (Nginx or Apache is fine) to C:\laragon

    That's all. I believe it should work for you.


  • | 490 points

    @leokhoa thanks for all the help, this has solved it.


  • administrators
    | 62136 points

    @Ryucchi : Cool, happy coding :relaxed:


  • | 691 points

    How about transferring older version of laravel in my laragon folder ?


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.