GuzzleHttp makes server unresponding

  • | 156 points


    I switched from Homestead to Laragon and I am super happy about it.
    It has one problem tho. My Http calls made using GuzzleHttp library makes the web server unresponsive.
    When I hit an endpoint with GuzzleHttp call, it just keeps loading but nothing ever happens. I can not load anything else from that point. I have to go to Laragon and restart it.

    I've searched this forum, but everything with GuzzleHttp is from 2016 and starts with "Internal Server Error".
    I dont get any errors. There is nothing in logs either.

    I am using nginx version. FastCGI.

    Any ideas what is wrong and how should I fix it?
    Thank you!

  • administrators
    | 131219 points

    @mprom :
    I don't know what's wrong but some users switched to Laragon + Apache and it worked.
    If you want to go with Nginx, you can try to increase the number of PHP Upstream Processes.
    Here's how:

    1. Open user\laragon.ini (Menu > Laragon > Settings file: laragon.ini)
    2. Put Upstream=X under [nginx] section

    Laragon will auto manage 5 PHP processes to handle requests.
    Hope it help.

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.