Symfony projects - 403 Forbidden

  • | 2329 points

    First of all, a really big thank you for building this. It saved me a lot of headaches when I had to shift to W10.

    I'm using Full + Nginx.

    Whenever I import, or even use the Quick create option, Symfony projects always display a 403 Forbidden error.
    I'm guessing permissions problems, but can't figure out how to solve it.

    Any help is apreciated. Thanks!

  • administrators
    | 130514 points

    @CØRE : New version of Symfony use app.php or app_dev.php for index (usually it's index.php)
    You can sort it out by:

    1. Open the Virtual Host: Menu > Nginx > sites-enabled >
    2. Update the index line:
    index index.html index.htm index.php app_dev.php;
    1. Reload Nginx.

    That's all. Enjoy :)

  • | 2329 points

    @leokhoa That works! Thanks for the help.

    However, new projects are not displaying the toolbar and displaying the following error.
    Obviously this only applies to app_dev.php


  • administrators
    | 130514 points

    @CØRE : Ah, as there is no index.php, you must change that line

    try_files $uri $uri/ /index.php$is_args$args;


    try_files $uri $uri/ /app_dev.php$is_args$args;

    then Reload Nginx.

  • | 2329 points

    @leokhoa Outstanding! Thanks for the great support! :clap:

    As a request, I'd like to see this configuration automatically applied to all Quick create projects if possibly in the future. I'll be keeping an eye on the updates changelog.

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.