Self-signed Cert Not Working Due to Chrome latest update

  • | 1171 points

    This issue happens because the reason below

    The certificate for this site does not contain a Subject Alternative Name extension containing a domain name or IP address.

    Any idea to fixed it ?
    I try to revise openssl.config but it seen doen't work

  • administrators
    | 132054 points

    You can check @Kurre's answer here:

    But your browser is nagging about untrusted certificate :disappointed:
    You need to add it as trusted certificate...In Chrome go to chrome://settings :arrow_right: Advanced settings :arrow_right: HTTPS/SSL :arrow_right: Manage certificates
    Now we need to import newly created certificate to Chrome's certificate store
    Select import and select file which you created earlier
    Important: Now you need to select the certificate store where you want to store this certificate.
    Select Place all certificates in the following store and to Certificate Store: select Trusted Root Certification Authorities
    Click Finish/OK and restart your browser. Now you can browse to without browser nagging about the certificate :)

    Hopefully you can get certificates working with this method..I wrote this text in a little rush, so please ask if you have some problems

  • | 1171 points

    @leokhoa sorry, I think you are misunderstanding...
    This issue happens due to latest chrome update, please check the link below

    I know how to whitelist the self-signed cert in the browser, as evidence, please view screenshot below,

    Please note that the cert is auto generated by laragon

    This is the error chrome show to me, missing SAN

    Imported to chrome

    The content of cert

    The solution I found :

    1. open config file in laragon\bin\apache\httpd-2.4.25-win64-VC14\conf\openssl.cnf

    2. follow solution in StackOverflow

    change * in alt_names to your own domain, eg mine is

    1. cd to laragon\etc\ssl, and run command below

    openssl req -x509 -nodes -sha256 -days 365 -newkey rsa:2048 -keyout {}.key -out {}.crt

    This is the cert generated

    change ssl cert path in auto.{}.conf, and import into chrome

    re-open browser and reload laragon


  • administrators
    | 132054 points

    @LostNCG : Nice solution!

  • | 495 points

    @LostNCG I have followed your guide but not working.
    Please help me!
    I attached openssl.cnf.

  • | 1171 points


    Your entire post just told me you have a problem, but nothing anymore, how can I help you?
    You should understand the correct way to ask a question before you post.

    1. Correct and complete enough logs
    2. Describe abnormally status/behavior in process (if any)
    3. Screenshot errors returned
    4. Understand what is the correct materials that would help in solving problem

    BTW, issue on automated SSL cert feature have been solved by @leokhoa , you can try

    1. Update laragon to latest version 3.3
    2. Clean your browser cache and restart the browser
    3. Restart laragon's apache server

  • | 495 points

    Hi @LostNCG ,
    Thanks for your reply!
    My problem is can't add "Subject Alternative name" into the newtonx.crt file.
    Although I did follow your step by step instructions at StackOverflow.
    Thanks for the support!

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.