cannot open sites on dev domain


  • | 911 points

    Hi,
    I cannot open my site on .dev domain weeks ago I was able to do that but now after holidays I'm back to work and I cannot open my sites with dev domain!

    Why is that?

    e.g: http://laravelproject.dev

    Thanks.


  • administrators
    | 64704 points

    @Robert-Nicjoo :
    Any error message?
    Does it work with Firefox?
    Can you try with .app as I'm afraid Google had changed something with .dev domain on Chrome.


  • | 911 points

    this is what i get

    `This site can’t be reached

    This site on the company, organization or school intranet has the same URL as an external website.

    Try contacting your system administrator.
    ERR_ICANN_NAME_COLLISION`

    if i use .app this is what i get:

    `
    This site can’t be reached

    indobook.app’s server DNS address could not be found.
    Try:
    Checking the connection
    Checking the proxy, firewall, and DNS configuration
    Running Windows Network Diagnostics
    ERR_NAME_NOT_RESOLVED
    `


  • administrators
    | 64704 points

    I've tested it works fine with the latest Chrome. You should check:

    • Entries on your hosts file
    • Your AV, Firewall,...

  • | 911 points

    ok, i tried with Edge it works but in chrome and Firefox no, I have no AV, and my firewall is default since i installed my windows i did no change.


  • administrators
    | 64704 points

    @Robert-Nicjoo: Try to flush DNS:

    ipconfig /release 
    ipconfig /renew 
    ipconfig /flushdns 
    

  • | 911 points

    sorry but i have no idea where should i do that!


  • administrators
    | 64704 points

    You type each command in the Terminal (Menu > Laragon > Terminal) or Command Prompt


  • | 911 points

    still same result "This site can’t be reached"


  • | 911 points

    any solution for that?
    Today I changed my windows and I installed version 3 (laragon-wamp) result is the same as before, after that I unistall it and installed older vesion 2 (laragon-full-apache) and now cannot find sql to run the software.


  • administrators
    | 64704 points

    @Robert-Nicjoo : What do you mean cannot find sql to run the software?
    There are nearly 16K downloads of Laragon 3 and only you stuck to issues so you should post some images and give me more details so I can help you easiler.


  • | 911 points

    No need to be angry dude! here is the image:

    0_1499871928967_Untitled.png

    and if i try to use Nginx will be this error:

    0_1499872615911_Untitled2.png


  • administrators
    | 64704 points

    Nice :). From the images I can see that you installed Laragon 2 over Laragon 3 (which use Nginx & MySQL 5.7.18).
    You can try:

    1. Exit Laragon
    2. Rename C:\laragon to C:\laragon.old
    3. Install Laragon to C:\laragon

  • | 911 points

    thanks I did it and it works, but keep in mind and search in your file sources what cause that .dev domain doesn't work on v.3 because now i'm using .dev on v.2 with no problem and an hour ago with v.3 wasn't able to do that!.


  • administrators
    | 64704 points

    Glad to hear it worked. Laragon 3 works for me so I can not reproduce.
    Thanks for reporting me!


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.