Peer Certificate cannot be authenticated


  • | 890 points

    Hello,

    I'm having that dreaded cacert.pem issue.

    • I've tried updating my cacert file here C:\myfiles\laragon\etc\ssl

    with this file

    https://curl.haxx.se/docs/caextract.html

    • and updated my php.ini to

    curl.cainfo = "C:\myfiles\laragon\etc\ssl\cacert.pem"

    but I still get this error:


    making the request failed (Peer certificate cannot be authenticated with given CA certificates): Array
    (
    )
    Array
    (
    [sbs] => GET&https%3A%2F%2Fopenapi.etsy.com
    [info] => Trying 151.101.189.224...
    Connected to openapi.etsy.com (151.101.189.224) port 443 (#0)
    ALPN, offering http/1.1
    Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
    TLSv1.2 (OUT), TLS header, Certificate Status (22):
    TLSv1.2 (OUT), TLS handshake, Client hello (1):
    TLSv1.2 (IN), TLS handshake, Server hello (2):
    TLSv1.2 (IN), TLS handshake, Certificate (11):
    TLSv1.2 (OUT), TLS alert, Server hello (2):
    SSL certificate problem: unable to get local issuer certificate
    Closing connection 0
    TLSv1.2 (OUT), TLS alert, Client hello (1):

    Not sure what is going on. It works if I manually disable SSL checks.

    I am using php-7.0.19-Win32-VC14-x64 and I installed a php oauth extension (the 7.0 Thread Safe x64 from here https://pecl.php.net/package/oauth/2.0.0/windows)

    Just wondering if anyone else has run into a similar issue? I'm trying to get the etsy api package to work.

    https://github.com/inakiabt/etsy-php

    Thanks.


  • | 2763 points

    Hi! I don't work with SSL to long, but maybe you get help's from there::
    https://stackoverflow.com/questions/24372942/ssl-error-unable-to-get-local-issuer-certificate

    BW


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.