Issue with MariaDB 10.2.8 not being able to connect


  • | 1115 points

    I'm not sure if this is a MariaDB issue or not, I would like to get some help if at all possible.

    After updating Laragon to v3.1.3 I ran into an issue with MariaDB not working properly. I then updated to Laragon3.1.4 and removed the data directory and added MariaDB 10.2.8. Everything work fine for a few days. I have been using MariaDB 10.2.8 as early as yesterday.

    Today I started everything as normal and I get the following error:

    Host 'localhost' is not allowed to connect to this MariaDB server

    This only happens I have found if I switch to MySQL 5.7.19 use it for another DB then try and go back to MariaDB 10.2.8.
    Is this possibly a conflict with MySQL and MariaDB structure?

    So I am just a bit confused as to why this would just start happening?

    Complete log of last ru:

    2017-09-06 16:18:48 2668 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
    2017-09-06 16:18:48 2668 [Note] InnoDB: Uses event mutexes
    2017-09-06 16:18:48 2668 [Note] InnoDB: Compressed tables use zlib 1.2.3
    2017-09-06 16:18:48 2668 [Note] InnoDB: Number of pools: 1
    2017-09-06 16:18:48 2668 [Note] InnoDB: Using generic crc32 instructions
    2017-09-06 16:18:48 2668 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
    2017-09-06 16:18:48 2668 [Note] InnoDB: Completed initialization of buffer pool
    2017-09-06 16:18:48 2668 [Note] InnoDB: Highest supported file format is Barracuda.
    2017-09-06 16:18:48 2668 [Note] InnoDB: Starting crash recovery from checkpoint LSN=93147303
    2017-09-06 16:18:49 2668 [Note] InnoDB: Last binlog file '.\mysql-bin.000012', position 30281
    2017-09-06 16:18:52 2668 [Note] InnoDB: 128 out of 128 rollback segments are active.
    2017-09-06 16:18:52 2668 [Note] InnoDB: Removed temporary tablespace data file: "ibtmp1"
    2017-09-06 16:18:52 2668 [Note] InnoDB: Creating shared tablespace for temporary tables
    2017-09-06 16:18:52 2668 [Note] InnoDB: Setting file '.\ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
    2017-09-06 16:18:52 2668 [Note] InnoDB: File '.\ibtmp1' size is now 12 MB.
    2017-09-06 16:18:52 2668 [Note] InnoDB: Waiting for purge to start
    2017-09-06 16:18:52 2668 [Note] InnoDB: 5.7.19 started; log sequence number 93147312
    2017-09-06 16:18:52 1952 [Note] InnoDB: Loading buffer pool(s) from C:\laragon\data\mysql\mariadb\mariadb\mariadb\ib_buffer_pool
    2017-09-06 16:18:53 2668 [Note] Plugin 'FEEDBACK' is disabled.
    2017-09-06 16:18:53 2668 [Note] Recovering after a crash using mysql-bin
    2017-09-06 16:18:53 2668 [Note] Starting crash recovery...
    2017-09-06 16:18:53 2668 [Note] Crash recovery finished.
    2017-09-06 16:18:53 2668 [Note] Server socket created on IP: '::'.
    

    I do notice that this line appears to be referencing MySQL and not the MariaDB version:

    2017-09-06 16:18:52 2668 [Note] InnoDB: 5.7.19 started; log sequence number 93147312
    

  • | 1115 points

    Here is the Laragon log:

    2017-09-06 16:35:19: Graceful shutdown failed!!! Did you change the root's password? - trying to force it shutdown...
    ERROR: C:\laragon\bin\mysql\mariadb-10.2.8-winx64\bin\mysqladmin: connect to server at 'localhost' failed
    error: 'Host 'localhost' is not allowed to connect to this MariaDB server'
    

  • administrators
    | 66215 points

    Did you change anything on root user or my.ini?


  • administrators
    | 66215 points

    @codebyray : I guess it is related to privileges. You can try reset root password at Menu > MySQL > reset root password


  • | 1115 points

    Have not changed anything in the my.ini file. I'm thinking it is something to do with Windows 10 possibly. Not sure.

    I can run MySQL 5.7.19 just fine and never experience an issue.

    If I rename data to data.bak and start MariaDB 10.2.8 and it will work fine. Of course I then have to create all new databases which is not ideal.

    I tried resetting the root password and here is the output I get:

    2017-09-06 18:08:17 Detect if MySQL is running...
    2017-09-06 18:08:17 Start MySQL server with --skip-grant-tables option
    2017-09-06 18:08:18 MySQL is running with PID 5928 (--skip-grant-tables)
    2017-09-06 18:08:18 Reseting root password & generating a random one...
    2017-09-06 18:09:28 Error occurred! 
    ERROR 1194 (HY000) at line 1: Table 'user' is marked as crashed and should be repaired
    
    2017-09-06 18:09:28 You may try resetting it manually: 
    https://laragon.org/?q=reset-mysql-password
    2017-09-06 18:09:28 Stopping MySQL - PID 5928 (--skip-grant-tables)...
    2017-09-06 18:09:35 Done.
    

  • administrators
    | 66215 points

    @codebyray : I guess there is an issue of your downloaded MariaDB 10.2.8 or your OS
    I tested with MariaDB 10.2.8 64-bit on Windows 10 and it works fine (many times).

    0_1504834792817_laragon-reset-pass.png


  • | 1115 points

    @leokhoa I'm running windows 10 also. Usually the issue happens after I stop MariaDB, start MySQL 5.7 do some database work and later or the next day when I am working on a project with MariaDB I start Maria and the issues occur.

    I've had this happen several times, have removed MySQL. Removed MariaDB and even completely removed Laragon and reinstalled. Still get the issue.

    Not sure why, but it started happening after I upgraded to version 3.1.4


  • administrators
    | 66215 points

    @codebyray :
    I mean when reseting MariaDB root password (after switching from MySQL), I did not see the "user table crashed error" like you.

    Actually, Laragon 3.1.4 did not change any thing in it's core.
    I just added features to support PHP 7.2 (which has breaking changes on PHP extensions)
    https://forum.laragon.org/topic/610/laragon-3-1-4-released-supports-php-7-2

    Don't worry, I'll keep working on your case.

    In the meantime, if you need to test with MariaDB, you can install Laragon 3.0 to another folder which includes MariaDB by default (You can install many Laragon version and run 1 at a time):
    https://sourceforge.net/projects/laragon/files/releases/3.0/


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.