Laragon 1.0.6 Release Announcement (with Mail Catcher + Mail Sender)


  • administrators
    | 66720 points

    • Released: 2016-02-22
      I am so excited to announce the release of Laragon 1.0.6
      This release has powerful features for mail:
    • Mail Catcher: When you send mail using mail() function, Laragon will show a small Windows on the bottom right of your screen and help you quickly view content of the generated email (and be sure that your mail() function works)
    • Mail Sender: You can use mail() function to send mail to Internet easily and effortlessly (and no more worry about being marked as Spam, complex SMTP server configurations,...). Just specify Gmail username/password (Don't need to be your Gmail, just another Gmail account you create for sending email)
    • Mail Analyzer: Analyze what happens when email is sent behind the scene and show helpful information to make sure that your email configurations are correct.

    Some images:

    0_1456150540456_laragon-caught-mail.png

    0_1456150563999_laragon-mail-catcher.png

    0_1456150587067_laragon-mail-sender.png

    0_1456150597688_laragon-mail-analyzer.png

    0_1456151615470_laragon-php-mail-catcher-menu.png

    0_1456151511562_laragon-php-mail-menu.png


  • | 2855 points

    I wanted to try this out, but it complains:
    Sorry, there is no file PEAR\PHPMailerAutoLoad.php in
    your PHP dir!

    c:\Development\laragon\bin\php\php-7.0.3-64-ts

    What steps can I do to solve this?


  • administrators
    | 66720 points

    • Just copy the php.ini & PEAR folder in c:\Development\laragon\bin\php\php-7.0.0
      to:
      c:\Development\laragon\bin\php\php-7.0.3-64-ts

    • Change anything in php.ini from 7.0.0 to 7.0.3-64-ts if needed


  • | 701 points

    Good job :+1: I must override previous install as usual ?


  • administrators
    | 66720 points

    Yes, there is no harm. Just stop your current Laragon and proceed :)


  • | 2855 points

    @leokhoa I did merge that php.ini with mine (and copied the pear dir), but without success. I get a black window (with at the bottom my address, and the option to resend it.)
    In your php.ini there is:
    ;sendmail_path = ""C:/lamp/bin\sendmail\sendmail.exe" -t"
    is that semicolon on purpose?

    I also have a php-cli.ini in the same php directory. It wouldn't use that one by the way?
    (since I didn't change that one)


  • administrators
    | 66720 points

    Hi @marcelloh: The black Windows means include_path is wrong in php.ini
    In your php.ini, the include_path should be like this:

    include_path=".;c:/Development/laragon/bin/php/php-7.0.3-64-ts/PEAR"
    

    You can search and change all the path in php.ini to right path
    C:/lamp ---> c:/Development ...etc

    For sendmail_path, when you click "Test Sending Mail..." button, Laragon will create a sendmail_path wih correct path for you. I'm sure you have another sendmail_path if you did that.


  • | 2855 points

    @leokhoa Yeah, I have that line pointing to the copied pear directory.
    Does everything has to be started to test this out?
    I just did and when I clicked a couple of times on retest, I see:
    C:\development\laragon>
    (in white font)
    but nothing more.
    And this also happens when I don't start apache and so on. I think, PHP takes my php-cli variant.
    Will change that now and see what happens.
    it does something more:
    Welcome to Laragon Mail Analyzer...
    and that's it. If i press retest, the screen gets black again.


  • | 2855 points

    @leokhoa After a while i now get more:

    Welcome to Laragon Mail Analyzer...
    2016-02-23 14:15:28 SMTP ERROR: Failed to connect to server: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
    (10060)
    2016-02-23 14:15:28 SMTP connect() failed.
    Mailer Error: SMTP connect() failed.
    C:\development\Laragon>


  • | 2855 points

    @leokhoa tried it with 2 different emailaccounts


  • administrators
    | 66720 points

    @marcelloh : Are they Gmail accounts?


  • | 2855 points

    @leokhoa one is my company account (which is gmail 4 business), and the other is private (which is gmail)


  • administrators
    | 66720 points

    @marcelloh: First, I congrats when you have something output that means Laragon Mail Analyzer works :)
    From the output, you'll have information why the email information are not accept and figure out..


  • | 287 points

    Congratulations on the release. With so many awesome new features this should have been version 1.1 though :bowtie:.

    Thank you so much @leokhoa


  • | 2855 points

    I sometimes have a problem, that apache died somehow, and laragon can't be closed down. So I have to kill the process. and after that, kill the httpd process. This didn't happen to me before this version. I can't figure out what causes this behaviour. I tried a lot of different things, but it seems unpredictable. Is there some logging option, or a debug option that I can use to help you figure out what happens?


  • administrators
    | 66720 points

    @marcelloh : You can check the error.log (Menu > Apache > error.log)


  • | 146 points

    Hi

    https://forum.laragon.org/topic/10/xip-io-problem?loggedin

    Version 1.0.6 with the same problem (app.IP.xip.io launch phpinfo() )

    Thanks


  • | 2855 points

    @leokhoa And this is the result when apache all of a sudden stops: (but I was now able to stop and start everything, which wasn't the case earlier)
    [Thu Mar 03 10:40:22.326837 2016] [mpm_winnt:notice] [pid 5632:tid 216] AH00428: Parent: child process 3668 exited with status 3221225477 -- Restarting.
    [Thu Mar 03 10:40:23.086457 2016] [ssl:warn] [pid 5632:tid 216] AH01909: www.example.com:8443:0 server certificate does NOT include an ID which matches the server name
    [Thu Mar 03 10:40:23.211259 2016] [mpm_winnt:notice] [pid 5632:tid 216] AH00455: Apache/2.4.18 (Win64) OpenSSL/1.0.2e PHP/7.0.3 configured -- resuming normal operations
    [Thu Mar 03 10:40:23.211259 2016] [mpm_winnt:notice] [pid 5632:tid 216] AH00456: Apache Lounge VC14 Server built: Dec 9 2015 11:13:29
    [Thu Mar 03 10:40:23.211259 2016] [core:notice] [pid 5632:tid 216] AH00094: Command line: 'C:\Development\laragon\bin\apache\apache-2.4.18_64vc14/bin/httpd -d C:/Development/laragon/bin/apache/apache-2.4.18_64vc14'
    [Thu Mar 03 10:40:23.226859 2016] [mpm_winnt:notice] [pid 5632:tid 216] AH00418: Parent: Created child process 6948
    [Thu Mar 03 10:40:24.512280 2016] [ssl:warn] [pid 6948:tid 228] AH01909: www.example.com:8443:0 server certificate does NOT include an ID which matches the server name
    [Thu Mar 03 10:40:24.639082 2016] [ssl:warn] [pid 6948:tid 228] AH01909: www.example.com:8443:0 server certificate does NOT include an ID which matches the server name
    [Thu Mar 03 10:40:24.654682 2016] [mpm_winnt:notice] [pid 6948:tid 228] AH00354: Child: Starting 64 worker threads.


  • administrators
    | 66720 points

    @marcelloh : It may relate to your Apache settings. There are many Laragon users and I did not hear about the same kind of error.


  • | 1447 points

    @leokhoa

    Sorry but i tried to install Laragon on a clean Windows 10 cmputer and on a clean never used Windows 8.1 image on a Mac but both gives the result as marcelloh...

    all Laravel 5 projects created ends with a default Lavaral 5 screen in the browser and in the error log like Marcelloh....

    www.example.com:8443:0 server certificate does NOT include an ID which matches the server name


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.