How I can change the .dev extension with .test to be able to continue developing usin chrome?

  • administrators
    | 123538 points

    @waul : Oh, I mean it is not Laragon's configuration.
    If you use Wordpress for 50 sites, please remember to update the siteurl and home options value:

  • | 390 points

    I'm also facing the same issue, since Google Chrome 63 update, out December 2017, domains with .dev are in the preloaded HSTS list with a rule enforcing HTTPS, no workarounds.

    IETF states a few reserved TLDs for development:

    To safely satisfy these needs, four domain names are reserved as
    listed and described below.


    ".test" is recommended for use in testing of current or new DNS related code.
    ".example" is recommended for use in documentation or as examples.
    ".invalid" is intended for use in online construction of domain names that are sure to be invalid and which it is obvious at a glance are invalid.
    The ".localhost" TLD has traditionally been statically defined in host DNS implementations as having an A record pointing to the loop back IP address and is reserved for such use. Any other use would conflict with widely deployed code which assumes this use.

    Here in the company however, we use Kaspersky and it blocks Laragon frome editing Hosts, therefore I can't seem to change from .dev to another thing. Here's what I did, without success:

  • | 1094 points

    @leokhoa Yes, That is it
    Thank you very much, now it works after changing from .dev to the new .test , I had to " update the siteurl and home options value" in every local site database then its URl open in chrome and firefox but with some images not found as their url contain .dev so I ran search and replace to replace every .dev with .test
    and finally yes it works
    Thank you again @leokhoa

  • | 1094 points

    @Lucas-Bustamante by the way I use also kaspersky so you may try to add laragon to the trusted apps in kasprsky settings, it may work for you

  • | 366 points

    @waul Actually i have solved my issue. Here is how
    STEP 1: Run Laragon
    STEP 2 Click on Gear symbol for settings
    STEP 3 Look for Hostname, it looks like this {name}.dev. Change .dev to wa or anything you like apart from .dev & .app and it will be solved.

    If you wish to update laragon just do the following as i have done it a few times
    STEP 1: Download the new version of laragon. I use this cos i prefer ngix
    STEP 2: Once download is complete, click install, this will update the old version files with the new one and you are fit to code again.

    Best Regards

  • administrators
    | 123538 points

    @waul :
    What a nuisance issue! The decision to force https on .dev and hard-coded it makes developers' lives harder.
    But at last, I'm glad to hear your issues are solved :)

  • | 1094 points

    @leokhoa Thank You :)

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.