the code execution cannot proceed because VCRUNTIME140.dll was not found. What to do?

  • | 4143 points

    I first installed laragon 3.1 on a fresh computer and while it worked I discovered there is 3.2 so I installed that version as well. After that I had to install Visual Studio Professional 2017 for some other non-php related work and after restarting the computer I get the message that you can see in the attached file


    What can I do to fix this? This popup came up couple of times after I closed it, perhaps 3-4 times after pressing OK

  • administrators
    | 131225 points

    @nermamax : There is a conflict between VC Redist version. I think you can try installing it manually.

  • | 4143 points

    I tried and got an error as well, it seems that VS 2017 has its own version of this runtime since I get an error that version of it already exists although when looking at add/remove programs I could see version for 2010, 2012, 2013 and 2017 but not 2015. I had to uninstall VS 2017 and install VS 2015 to even make it work in case someone runs into same issue :)

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.