MySql or MariaDB not starting

  • | 1037 points

    Hi all,

    I got problem with MySql- it doesn't start for some reason.
    First I had version 2 installed, then I updated to v 3. Everything was fine. Then one day my Kaspersky showed notification about Apache, I clicked on "Do not block" or something like that, but Laragon stopped working. Then I tried all different ways to fix it, finally I reinstalled Laragon- Apache is starting ok, but not MySql (or MariaDB).
    Now I made a backup of my data, deleted everything in "data" folder and ran mysqld --console. It's been like this for around 3 hours now. What else can I do to make MySql start?

    I would appreciate any help :)

    xxx@DESKTOP-I2FAK96 C:\laragon\bin\mysql\mysql-5.7.21-win32\bin

    mysqld --console
    2018-01-30T10:22:15.707067Z 0 [Note] --secure-file-priv is set to NULL. Operations related to importing and exporting data are disabled
    2018-01-30T10:22:15.710958Z 0 [Note] mysqld (mysqld 5.7.21) starting as process 17460 ...
    2018-01-30T10:22:15.884101Z 0 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
    2018-01-30T10:22:15.888523Z 0 [Note] InnoDB: Uses event mutexes
    2018-01-30T10:22:15.888862Z 0 [Note] InnoDB: Memory barrier is not used
    2018-01-30T10:22:15.889254Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.3
    2018-01-30T10:22:15.895163Z 0 [Note] InnoDB: Number of pools: 1
    2018-01-30T10:22:15.904852Z 0 [Note] InnoDB: Not using CPU crc32 instructions
    2018-01-30T10:22:15.912354Z 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
    2018-01-30T10:22:15.924516Z 0 [Note] InnoDB: Completed initialization of buffer pool
    2018-01-30T10:22:16.149362Z 0 [Note] InnoDB: The first innodb_system data file 'ibdata1' did not exist. A new tablespace will be created!
    2018-01-30T10:22:16.160043Z 0 [Note] InnoDB: Setting file '.\ibdata1' size to 12 MB. Physically writing the file full; Please wait ...
    2018-01-30T10:22:16.194635Z 0 [Note] InnoDB: File '.\ibdata1' size is now 12 MB.
    2018-01-30T10:22:16.284007Z 0 [Note] InnoDB: Setting log file .\ib_logfile101 size to 48 MB
    2018-01-30T10:22:16.603510Z 0 [Note] InnoDB: Setting log file .\ib_logfile1 size to 48 MB
    2018-01-30T10:22:16.974306Z 0 [Note] InnoDB: Renaming log file .\ib_logfile101 to .\ib_logfile0
    2018-01-30T10:22:17.005924Z 0 [Warning] InnoDB: New log files created, LSN=45790
    2018-01-30T10:22:17.030545Z 0 [Note] InnoDB: Creating shared tablespace for temporary tables
    2018-01-30T10:22:17.069744Z 0 [Note] InnoDB: Setting file '.\ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
    2018-01-30T10:22:17.131478Z 0 [Note] InnoDB: File '.\ibtmp1' size is now 12 MB.
    2018-01-30T10:22:17.142064Z 0 [Note] InnoDB: Doublewrite buffer not found: creating new
    2018-01-30T10:22:17.166024Z 0 [Note] InnoDB: Doublewrite buffer created
    2018-01-30T10:22:17.168810Z 0 [Note] InnoDB: 1 redo rollback segment(s) found. 1 redo rollback segment(s) are active.
    2018-01-30T10:22:17.172386Z 0 [Note] InnoDB: 32 non-redo rollback segment(s) are active.
    2018-01-30T10:22:17.227016Z 0 [Warning] InnoDB: Creating foreign key constraint system tables.

  • administrators
    | 131219 points

    @roland: If you use Laragon 3, just delete data folder, then click "Start All" - MySQL will work again. Then, you can restore from your backup.

  • | 1037 points

    Thanks for quick reply :)

    Unfortunately that didn't help. Everything went ok, but this is what I get when I try to connect to MySql:

    What else can I try?

  • administrators
    | 131219 points

    @roland : Can you switch back the port to 3306?

  • | 1037 points

    @leokhoa no luck..

    Maybe this would help?

    2018-01-30 16:42:06: Graceful shutdown failed!!! Did you change the root's password? - trying to force it shutdown...
    ERROR: mysqladmin: connect to server at 'localhost' failed
    error: 'Can't connect to MySQL server on 'localhost' (10061)'
    Check that mysqld is running on localhost and that the port is 3306.
    You can check this by doing 'telnet localhost 3306'

    It's from laragon.log

  • administrators
    | 131219 points

    @roland : Can you try:

    1. Delete the data dir
    2. Start MySQL
    3. Check if it work first?

    @leokhoa said in MySql or MariaDB not starting:

    @roland: If you use Laragon 3, just delete data folder, then click "Start All" - MySQL will work again.

  • | 1037 points

    @leokhoa, looks like it fnally worked! :) I don't know why it didn't work yesterday :) I'll try to import my data and let you know if everything went ok :)

  • administrators
    | 131219 points

    Nice! I think it is because of the port.
    I'm pretty sure with you if you delete the data dir, MySQL will work again 100% with new clean data - That makes MySQL (or Postgres/MongoDB) is super easy & safe to operate under Laragon.

  • | 1037 points

    I switched port back to 3308 and eveything is ok :)
    I couldn't import my databases, but I found that sql file is not full. I'll get them from production server, no biggie :)
    Thanks a lot for your help and support :)

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.