updated to latest phpmyadmin, cant see my old databases

  • | 4143 points

    I updated first to latest laragon version 3.2.3

    since I am now running php 7.2 I had to update phpmyadmin as well, as I updated the errors I had with older phpmyadmin where gonne but now I only see information_schema and test datababases, I can't see my previous databases. When I tried to create new database inside phpmyadmin got this error:

    #1044 - Access denied for user ''@'localhost' to database 'test55'

    When I tried to create this database using laragon interface for MariaDB I got response that database already exists.

    Perhaps I do not even have permissions to the view files inside database anymore? How do I fix this? I have enabled loging in to phpmyadmin without password.

    What do I need to configure to get phpmyadmin to work again with mariadb?

  • administrators
    | 131219 points

    @nermamax : What was your former Laragon's version?

  • administrators
    | 131219 points

    If you upgrade from Laragon 2.2, you must follow this instruction:

  • | 4143 points

    yes I was using laragon 2.2.2

    you wont belive this, I do not know what happen but I did not follow the procedure above. I installed laragon into the laragon folder as previous version, I did not dump and restore the database since I was not aware there was procedure for updating from 2.2.2 to 3.2.3 and after first restart om my machine I had some troubles, I could not even run yarn or node, I could not see my databases and I could not create any new databases. I then manually add a path to nodejs and point the folder to laragon/node I restart my computer once again and voila everything works. phpmyadmin can now suddenly show me all databases, I can create new databases, I can do everything that I was not able to do moments ago, and ofc yarn, npm and node are working as well.

    So I dont know what happens, perhaps its a ghost in a machine but without following the required procedure you linked to, I got everything working except for one thing, Yarn reports 1.2.1 while this page specifies yarn at 1.3.2


    Not sure why yarn 1.2.1 is still running, but mostly eveything else is working at 100% now

    edit: Also on that page its mentioned PHP 7.2.0 while I got 7.2.2 and node is at v6.9.5 on my machine while on that page v8.9.1

  • administrators
    | 131219 points

    @nermamax : I'm glad to hear it works now. I released Laragon 3.2.3 a few days ago so you have PHP 7.2.2

    • For yarn:
      You can remove your yarn folder, then install Laragon over.

    • For nodejs:
      You should not manually add nodejs to PATH, just click Menu > Node.js > version > node-xxx

    Hope it help :)

  • | 4143 points

    When I press menu and node > version this is what I see


    Is there sometihng there I should now click? maybe node-v8 should be clicked?

    So you would recommend to completly reinstall laragon if I want latest yarn version instead of just me manually downloading and installing yarn into laragon/bin/yarn? I did that last time, it was recommended here on forum if one wanted newer version of yarn and I was still running on 2.2.2 which had older version...

  • administrators
    | 131219 points

    @nermamax : Just click node-v8!

    " just me manually downloading and installing yarn into laragon/bin/yarn": it should work but I think the faster way is install Laragon. It's up to you :)

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.