{name}.dev:82 not running on different port


  • | 220 points

    0
    down vote
    favorite
    i have checked auto virtual hosts on my laragon, this virtual host was created, but since i am running on port 82 and not the default port 80 i cannot access

    sample.dev:82

    nor

    localhost:82/sample.dev

    i have this in my hosts file

    127.0.0.1 sample.dev #laragon magic!

    i even tried putting the port number after the 127.0.0.1:80

    127.0.0.1:82 sample.dev #laragon magic!

    and

    127.0.0.1 sample.dev:82 #laragon magic!

    neither is working, how do i access sample.dev on my web browser

    <VirtualHost *:82>
    DocumentRoot "C:/laragon/www/sample/public/"
    ServerName sample.dev
    ServerAlias *.sample.dev
    <Directory "C:/laragon/www/sample/public/">
    AllowOverride All
    Require all granted
    </Directory>


  • administrators
    | 93419 points

    @kzish : Can you try?:

    1. Change the hostname format to {name}.test in Menu > Preferences
    2. Change the Apache port in Menu > Services and Ports

  • | 220 points

    {name}.test was the solution
    thank you for that
    now my question is why does {name}.test work and {name}.dev not work?


  • administrators
    | 93419 points

    @kzish : I glad it helped :)
    If you want to know the reason, please read:
    https://forum.laragon.org/topic/764/important-dev-domains-chrome-63


Log in to reply
 

Looks like your connection to Laragon was lost, please wait while we try to reconnect.