no "port 80 in use" check?

  • | 836 points

    I had to reset my PC, did a fresh install of Win10, installed all necessary software via the awesome service of (no spam, really recommend it - please remove the link if that violates your forum rules) and finally installed laragon (which I'm using since several months and really love it!).

    The problem: I always got a blank white screen in my browser, no matter which laragon-site I tried. It took me quite some time to find the culprit: A blocked port 80 by one of those f** tools that are installed by some other software...

    It would have been really great to get a notification by Laragon that port 80 is already in use. If this should already be the case: There was none. I got no error, everything seemed to work. Just got a blank white screen in my browser...

  • | 1818 points

    @bernhard probably the problem is the port 80 used in skype. You can change the port in settings from skype:


    (picture from

    You need uncheck "use port 80 and 443 to alternative..." for use this ports only if other programs not are used when skype starts

  • administrators
    | 131225 points

    @bernhard: Nice idea!
    Laragon has a netstat button (Menu > Tools > netstat) to detect which programs (+ their paths) are using which ports.
    However, many new developers may give up using Laragon when they experience this kind of error.

  • | 836 points

    @leokhoa thanks, I know about this button now, because I did some research before posting my request. Though, as you mentioned, it was not obvious to me that this could be the problem. And I'm sure there might be others that have the same problem and don't know what's going and and what could be the best to fix it.

    @condemned thx I know that I had problems with skype and laragon some months ago and fixed it like you showed at that time. But same as above: This time it was just not obvious as I got no error, no hint, nothing. So I just didn't think of checking port 80...

  • | 1818 points

    @bernhard if you can't solve like that, i'm proceed to test for find the solution :)

  • | 836 points

    @condemned sorry I don't understand you. I already fixed it. I know how to find programs that block port80 and disable/reconfigure them. The problem was just that I didn't think of that issue and got no hint by laragon. That was my intention of this post.

Log in to reply

Looks like your connection to Laragon was lost, please wait while we try to reconnect.